Activar multitouch en el touchpad de las HP Mini

Una actualización del driver del touchpad de las HP Mini, permite a las netbooks tener soporte multitouch y de unas gesturas:

  • Scroll usando dos dedos.
  • Llamar a una aplicación al presionar con 3 dedos
  • Usar 3 dedos para desplazarse (atrás o adelante) entre fotos o en el historial de navegación

En mi HP Mini 1000 ha funcionado perfectamente. Lo único es que el área del touchpad no es muy grande que digamos.

Se viene el firmware 1.1.3 del iPhone / iPod Touch

Todo parece indicar que en Enero tendremos una actualización al firmware 1.1.3 del iPhone / iPod Touch. Esta ocasión como ya es costumbre, el jailbreak dejará de funcionar ya que incluye nuevos parches que permitían hacerlo, así como las aplicaciones de terceros parece que dejarán de funcionar hasta que sean actualizadas a esta versión del firmware.

Las características del firmware 1.1.3 son bastante llamativas, más si eres dueño de un iPhone:

  • Se pueden enviar SMS a varias personas.
  • Google Maps puede localizar tu ubicación usando triangulación con las celdas de la red (talvez solo funcione en EEUU).
  • Google Maps mostrará la vista Híbrida (Mapas + Satelite)
  • Se pueden reordenar los íconos del SpringBoard (la portada del iPhone) con solo arrastrarlos y soltarlos (el video en gizmodo muestra bien el proceso). Antes de 1.1.3 tenías que usar iBrick, Customize o editar un archivo como los machos de verdad
  • SpringBoard soporta paginación. Antes esto estaba disponible mediante SummerBoard.
  • Ahora se podrán agrear favoritos a páginas web en el SpringBoard

En GearLife hay una galería mostrando algunas de estas nuevas características en acción.
Y así inicia una vez más la carrera por liberar el 1.1.3 mientras Apple tratará de cerrar más agujeros.

Etiquetas: , , actualizaciones, , , , gps

Actualizar a Ubuntu 7.10 Gutsy Gibbon y no morir en el intento

Hoy la ultima versión de Ubuntu ya está liberada oficialmente, con ello muchos estarán bajando los ISOs o bien haciendo actualizaciones desde Feisty Fawn. Cuando actualize de Edgy Eft a Feisty Fawn, aprendí dos buenas lecciones:

  1. No actualizar el mismo día de la liberación, no solo por la saturación de los servidores sino por los bugs que aparezacan… yo sufrí uno :-/.
  2. Usar servidors espejo, de preferencia uno cercano a tu localidad, incluso varios días después de que sea oficial la nueva versión.

Para usar un servidor en otra localidad, tienes que editar /etc/apt/sources.list y remplazar http://archive.ubuntu.com/ubuntu por la dirección del servidor que has elegido. Al menos yo, actualizaré hasta la otra semana usando un servidor en Suiza jeje.

Etiquetas: , , , , ,

WordPress 2.3 liberado, ¡beware!

Finalmente luego de varias versiones betas y Release Candiate, hoy está disponible el nuevo WordPress 2.3. Esta versión incluye algunos cambios importantes:

  • El soporte para etiquetas que ya ha sido incluido en WordPress.com. Aún más importante que el soporte de etiquetas son los cambios en el esquema de la base de datos, mismos que provocaron el retraso en WordPress 2.2, se está cambiando la forma en como los posts son relacionados con las categorías y las etiquetas.
    El gran problema es que hay plugins y plantillas que realizan consultas a la base de datos, sin utilizar la API de WordPress, que ahora pueden ser incompatibles; pueda que existan nuevas versiones de estos, sino tocará buscar otra solución o hacer los cambios a mano.
  • Sistema de notificaciones de nuevas versiones en plugins. Ahora al ver la página de los plugins instalados en WordPress (¿por qué no está esto en el Dashboard???) recibirás un aviso de si existe una nueva versión del plugin. En Wp-Hackers se ha desatado una discusión bastante candente sobre este sistema y los datos que WordPress 2.3 envía a api.wordpress.org, pero es algo que quiero confirmar. Si alguien no quiere que WordPress envíe datos, puede instalar este plugin que deshabilita esta característica por completo.
  • Mejor tratamiento de las URLS, dependiendo de la configuración de los permalinks ahora WordPress revisará si la URL termina en / o incluso si está incompleta WordPress buscará el post que más se le parezca, si lo hay. Mark ha explicado mejor el tema de las URLs canónicas en WordPress 2.3
  • Mejoras en la administración de borradores, con la característica de post pendientes de revisión. Algo que solo les servirá a quienes tiene muchos autores en su blog y están bien organizados… o casi
  • Otros 350 cambios en tickets cerrados en el Trac de WordPress

Para los que tenemos un WordPress muy personalizado/hackeado es un problema que hagan cambios en la Base de datos. Yo normalmente solo subo los archivos que han cambiado entre versión, pero en esta ocasión haré una migración desde cero… lo cual es bastante laborioso, tendré que hacer pruebas antes de hacerlo en el sitio real. Además aprovecharé para actualizar todas las versiones de los plugins y arreglar la plantilla.

Tengo el presentimiento que algo va a tronar… pero bueno: no risk, no fun.

» Descargar WordPress 2.3 en zip o tar.gz

Etiquetas: , , ,

Agrega tu comentario

Llego el día: Actualizando a Feisty Fawn

Hoy finalmente ya esta disponible la nueva versión de Ubuntu: Feisty Fawn (7.04). Yo por lo pronto no bajaré el CD (voy a esperar que vengan), mis dos intalaciones de ubuntu las voy a actualizar en caliente XD, justo ahora estoy actualizando mi Linux Mint (basado en Edgy) para no perder tiempo 😉

Actualizando de Edgy a Festy

Por ahora solo he tenido que eliminar algunos repositorios extras, ya que no respondieron a tiempo jejeje.

Actualizando de Edgy a Festy

Listo, llego la hora de bajar todo el montón de paquetes, 839 MBs…. espero no tarde mucho XD

Actualizando de Edgy a Festy

Voy a ir actualizando esta entrada, a ver que tal me va.

10:22 AM : La actualización iba lenta, así que mande a volar el Wizard de actualización. He modificado mi /etc/apt/sources.list a fin de utilizar un sitio espejo y que las descargas vayan más rápido, según se menciona acá. Básicamente lo que hay que hacer es reemplazar “http://archive.ubuntu.com/ubuntu” con alguno de los sitios espejo. Antes la velocidad de descarga era unos 20Kb/s ahora van a 60Kb/s y con buenos ratos de 80Kb/s :D. BTW ya también me pase a apt-get dist-upgrade para hacer las cosas más sencillas (como dice sirgt, cero stress jejeje)

Actualizando de Edgy a Festy - desde consola ;)

Etiquetas: , , , , , , .

WordPress 2.1.3 y 2.0.10

Luego de un mes después de que WordPress sufriera un crackeo y lanzaran una nueva versión de emergencia; hoy llega una nueva versión con bastantes bugs reparados, problemas con XSS y XML-RPC, además de medidas contra futuros problemas. Altamente recomendable que te actualices si tu blog/sitio tiene bastantes enemigos jejeje.

La verdad se tardaron un poco en lanzarla porque los RCs estuvieron listos desde hace muchos días atrás, probablemente el retraso se deba a que tomaron medidas más drásticas contra los hackeos al sitio y un bug de ultima hora. En fin, otro release más, por si quieren aprovechar la baja de tráfico por las vacaciones. Es una suerte que almenos mi blog no lo tenga que actualizar cada mes 😉

Descargar >> WordPress 2.1.3 o bien 2.0.10.

Actualización: Les recuerdo que para fin de mes tenemos la actualización hacia WordPress 2.2. Cuando dijeron desarrollo rápido, no creí que incluyera tantas actualizaciones por mes :S

Etiquetas: , , ,

Importante actualización de PHP en Dreamhost

Actualización: Al parecer es más una cagada de Dreamhost que un problema de los scripts y php5.2, como era de esperarse. Matt confirma que no debe haber problemas con php5.2. Seguramente Dreamhost dira que la respuesta es 42 😉

Si tienes una cuenta en Dreamhost con un dominio bajo PHP 5, utilizando WordPress, MediaWiki o ZendCart; preparate porque este Lunes 19 de Febrero, Dreamhost hará una importante actualización hacia PHP 5.2 (ojalá fuera hacia 5.2.1, porque no queda claro cual versión es). Debes actualizar tus scripts ya que algunas versiones de estos no funcionan correctamente con la actualización de php. Las versiones compatibles son:

  • WordPress 2.1
  • MediaWiki 1.9.2
  • ZendCart 1.3.7
  • A Drupal hay que aplicarle un parche.

Si utilizas algún otro script, asegurate de que este sea compatible. También podrías optar por cambiar la configuración del dominio hacia PHP4, pero es mejor que actualices por razones de seguridad.

Más información: PHP5 Downgrade Complete/Upgrade Scheduled for 02/19

Etiquetas de búsqueda: , , , , , , ,