Fin del ciclo de vida para PHP4

Hoy PHP.net anuncia el fin del ciclo de vida para PHP4, luego de tres largos años desde la liberación de PHP5. Los desarrolladores anunciaron de despues de 31 de diciembre de este año ya no habrán más versiones de php4 y que seguirán lanzado exclusivamente versiones de parches de seguridad hasta el 8 de Agostso de 2008.

Este anuncio sumado a la campaña de GO PHP5, son claros indicios de que es hora de moverse definitivamente a php5 y empezar a aprovechar sus bondades.

Etiquetas de búsqueda: , ,

GoPHP5.org, quitando el soporte a PHP4

GoPHP5PHP4 ya tiene siete años de haber se liberado, y PHP5 ya casi llega a los 3 años de estar en el aire; pero a pesar de ello muchos hostings aun no han agregado soporte para php5 por temor a que las aplicaciones de sus clientes no funcionen, o al menos no lo activan por defecto. De acuerdo con Nexen.net el 80% de los hostings aún continuan usando php4 en sus servidores.

Es por ello que nace GoPHP5.org, como una iniciativa para que los proyectos basados en php abandonen el soporte a PHP4 y se pasen a PHP5, aprovechando sus ventajas; así como comprometer a los hostings para que ellos también eliminen php4 de sus servidores.

La meta es llegar 5 de Febrero de 2008 con el mínimo soporte para php4. Proyectos como Drupal 7 y phpMyAdmin ya se han comprometido a esta iniciativa, y otros como MediaWiki desde ya solo corren en php5. En la lista de correo wp-hackers ya han discutido el cambio hacia php5 varias veces ya. La respuesta siempre ha sido: cuando exista mayor soporte de php5. Haber que pasa esta vez 😉

Etiquetas de búsqueda: , , , , ,

Importante actualización de PHP en Dreamhost

Actualización: Al parecer es más una cagada de Dreamhost que un problema de los scripts y php5.2, como era de esperarse. Matt confirma que no debe haber problemas con php5.2. Seguramente Dreamhost dira que la respuesta es 42 😉

Si tienes una cuenta en Dreamhost con un dominio bajo PHP 5, utilizando WordPress, MediaWiki o ZendCart; preparate porque este Lunes 19 de Febrero, Dreamhost hará una importante actualización hacia PHP 5.2 (ojalá fuera hacia 5.2.1, porque no queda claro cual versión es). Debes actualizar tus scripts ya que algunas versiones de estos no funcionan correctamente con la actualización de php. Las versiones compatibles son:

  • WordPress 2.1
  • MediaWiki 1.9.2
  • ZendCart 1.3.7
  • A Drupal hay que aplicarle un parche.

Si utilizas algún otro script, asegurate de que este sea compatible. También podrías optar por cambiar la configuración del dominio hacia PHP4, pero es mejor que actualices por razones de seguridad.

Más información: PHP5 Downgrade Complete/Upgrade Scheduled for 02/19

Etiquetas de búsqueda: , , , , , , ,