WordPress 2.3 liberado, ¡beware!

Finalmente luego de varias versiones betas y Release Candiate, hoy está disponible el nuevo WordPress 2.3. Esta versión incluye algunos cambios importantes:

  • El soporte para etiquetas que ya ha sido incluido en WordPress.com. Aún más importante que el soporte de etiquetas son los cambios en el esquema de la base de datos, mismos que provocaron el retraso en WordPress 2.2, se está cambiando la forma en como los posts son relacionados con las categorías y las etiquetas.
    El gran problema es que hay plugins y plantillas que realizan consultas a la base de datos, sin utilizar la API de WordPress, que ahora pueden ser incompatibles; pueda que existan nuevas versiones de estos, sino tocará buscar otra solución o hacer los cambios a mano.
  • Sistema de notificaciones de nuevas versiones en plugins. Ahora al ver la página de los plugins instalados en WordPress (¿por qué no está esto en el Dashboard???) recibirás un aviso de si existe una nueva versión del plugin. En Wp-Hackers se ha desatado una discusión bastante candente sobre este sistema y los datos que WordPress 2.3 envía a api.wordpress.org, pero es algo que quiero confirmar. Si alguien no quiere que WordPress envíe datos, puede instalar este plugin que deshabilita esta característica por completo.
  • Mejor tratamiento de las URLS, dependiendo de la configuración de los permalinks ahora WordPress revisará si la URL termina en / o incluso si está incompleta WordPress buscará el post que más se le parezca, si lo hay. Mark ha explicado mejor el tema de las URLs canónicas en WordPress 2.3
  • Mejoras en la administración de borradores, con la característica de post pendientes de revisión. Algo que solo les servirá a quienes tiene muchos autores en su blog y están bien organizados… o casi
  • Otros 350 cambios en tickets cerrados en el Trac de WordPress

Para los que tenemos un WordPress muy personalizado/hackeado es un problema que hagan cambios en la Base de datos. Yo normalmente solo subo los archivos que han cambiado entre versión, pero en esta ocasión haré una migración desde cero… lo cual es bastante laborioso, tendré que hacer pruebas antes de hacerlo en el sitio real. Además aprovecharé para actualizar todas las versiones de los plugins y arreglar la plantilla.

Tengo el presentimiento que algo va a tronar… pero bueno: no risk, no fun.

» Descargar WordPress 2.3 en zip o tar.gz

Etiquetas: , , ,

Agrega tu comentario

Servidores de Ubuntu comprometidos

En Slashdot han publicado la noticia de que varios servidores de Ubuntu, mantenidos por LoCos por patrocinados por Canonical, han sido comprometidos.

Entre los problemas que permitieron que estos servidores fueran comprometidos, señalan:

  • Mala administración de parte de los miembros del LoCo, al no aplicar parches de seguridad
  • Uso de FTP en lugar de SFTP
  • Exceso de uso de aplicaciones web, todas en versiones atrasas e inseguras.

La parte curiosa, es que varios parches de seguridad en el Kernel no pudieron ser aplicados por problemas con el hardware, del cual parte fue donado por Canonical. Las soluciones que Canonical presenta a los LoCo son:

  • Mover los servidores al Centro de Datos de Canonical, para tener soporte completo del equipo de Canonical pero con muchas más limitaciones.
  • Quedarse en un hosting externo, sin soporte de Canonical y con mucha mayor responsabilidad.

Este es un revés para Canonical que quiere incursionar el en mundo de los Servidores, ahora les lloverán críticas en especial de los de Debian que no aceptan a Ubuntu jeje. Ahh el trabajo diario de los sysadmins 😉

Etiquetas de búsqueda: , , , , ,