Driver ATI Catalyst 8.1 para GNU/Linux (fglrx 8.45.2) liberado

ATI ha liberado una nueva versión de su driver para GNU/Linux, que tiene tres puntos importantes a resaltar:

  • Soporte para Ubuntu 7.10
  • La resolución máxima permitida en monitores hasta 1680×1050 (antes 1280×1024)
  • Resuelve un bug muy molesto que llenaba la esquina inferior izquierda de la pantalla con “basura” o lineas erróneas, luego de mucho tiempo sin reiniciar:

    Bug en fglrx

Ya instalé el driver en mi Feisty Fawn y hasta el momento el molesto bug ya no ha regresado 🙂

Etiquetas: , ubuntu, , ,

Petición de soporte para GNU/Linux en Starcraft 2

Con el reciente anuncio de Starcraft 2 se abre de nuevo el viejo debate de la falta de soporte hacia Linux de parte de los desarrolladores de juegos. En el caso de Blizzard oficialmente solo existe soporte para Mac y Windows.

Para los usuarios linux no hay de otra más hacerse escuchar y firmar esta petición de soporte de los productos Blizzard en Linux:

To: Blizzard Inc.

We the undersigned would like to see native Linux installers for the products of Blizzard Inc. It is only fair that Blizzard’s products designed for both Windows and Mac should be made compatible with Linux as well, especially due to the popularity of Blizzard’s released products (StarCraft, WarCraft, WoW, etc.) and their upcoming releases (StarCraft 2).
The computer world is about choices now. Not everyone wants to be stuck with a Windows or a Mac. Some people use Linux, BSD, and other OS types.
It is also suggested that perhaps the installers be released with open-source code, to adjust the installers to other various systems (BSD, Solaris, other distributions of Linux)
The installer should be in a .run file, and require the user to have already bought the product (hence a CD detection)
Blizzard’s games are hailed as some of the most influential games around, and it is about time that companies start adopting the business practices of id Software.

Sincerely,

The Undersigned

Nunca está demás tener opciones 😀

Imágenes de Stickers para Distribuciones GNU/Linux

Navegando por gnome-look.org, llegue a una colección stickers con los logotipos de diferentes distribusiones GNU/Linux: Mandriva, SuSE, Ubuntu, Kubuntu, CentOS, Debian, Fedora, Xubuntu, ArchLinux, Gentoo, Slackware, Edubuntu, KateOS y uno general de Linux.

Útiles por si quieres imprimir tus stickers o hacer fondos de escritorio con ellos. Están disponibles en versión SVG.

>> Stickers 7

Etiquetas de búsqueda: , , , , ,

gTwitter, cliente twitter desde GNU/Linux

Muchos ya caímos con Twitter (aunque uno que otro aún se resiste) y estamos engachados a él :P. El sitio de twitter ha ido lento esta semana (bueno hasta hoy va más rápido), los envíos via IM esta fuera, y tener una pestaña abierta en Firefox solo para twitter no es el caso.

Así que para los que usamos GNU/Linux llego gTwitter, un pequeño cliente basado en Mono y algunas librerías Gnome, e inspirado en Twitterrific el respectivo cliente en Mac para Twitter.

gTwitter - Cliente sobre Linux para Twitter

Tiene las funciones básicas: ves lo que hacen tus amigos, puedes agregar las tuyas, tiene cache de imagenes, y se actualiza cada cierto tiempo (configurable). Para instalarlo o bien bajas el binario o descargas los fuentes para compilarlo. gTwitter aún esta en desarrollo, así que probablemente veremos más mejoras 😉

Etiqueta: , ,

Virus fuera del mundo Windows

A veces cuando uno habla con los fanboys de GNU/Linux o Mac pareciera que están completamente convencidos que SU sistema es infalible; aunque si hay que reconocer que la seguridad está mejor implementada por defecto comparado con Windows. Paquete

Conforme estas dos plataformas se popularizan y hay más usuarios neófitos usándolas, las probabilidades de ver noticias en Digg como la de “Miles de macs infectados por un trojano en software pirata” se incrementan, pasándose de largo toda la supuesta gran seguridad comparada a la de Windows… y todo por culpa de un usuario que no sabe. Esos trojanos seguirán dando vueltas por un tiempo, y si esos usuarios tuvieran un antivirus quizás no estarían tan indefensos.

Tampoco quiero decir que los Antivirus sean la quinta maravilla, yo los odio, detesto la cantidad de recursos que consumen a diario cuando en realidad son útiles muy pocas veces. Mi Windows no tiene antivirus porque creo saber lo que hago, y en el peor de los casos se como eliminar los problemas.

Si el usuario es estúpido, no habrá sistema que lo defienda, no importando si es del pingüino, la manzana de la discordia o la ventana.

Como hacer que el iPhone / iPod Touch recarge la batería en Linux

Hace unos días descubrí con desagrado que mi iPod Touch (y por tanto el iPhone) no recarga la batería al conectarlo en Linux. Todo el problema es que hay que enviar una secuencia al iPod / iPhone cuando este se conecta al USB, así como hacer una pequeña modificación al Kernel de linux para que no suspenda el dispositivo y pueda cargar la batería sin problema.

Para que el iPod Touch / iPhone pueda recargarse en linux necesitamos al menos la versión 2.6.22 del Kernel, Ubuntu 7.10 (Gusty Gibson) ya incluye esta versión. Luego necesitamos bajar el iPhone Module, el modulo del kernel que se encargará de enviar los datos apropiados al iPhone.

Si tienes un iPod Touch, necesitas modificar el valor de #define IPHONE de 0x1290 a 0x1291. Luego para ambos iPhone y iPod hay que agregar la linea de código:

udev->autosuspend_disabled = 1;

Esto es para que el Kernel no suspenda el dispositivo. Yo agregue esta instrucción en la función iphone_probe en iphone.c, que al final quedó así:

static int iphone_probe(struct usb_interface *intf,
                       const struct usb_device_id *id)
{
       struct usb_device *udev = interface_to_usbdev(intf);

       if (udev->actconfig->desc.bConfigurationValue == 3) {
               dbg(&udev->dev, "Configuration changed");
               return -ENODEV;
       }

       /* turn the power on */
       select_configuration(udev);

	udev->autosuspend_disabled = 1;

       /* we don't really want to bind to the device, userspace programs can
        * handle the syncing just fine, so get outta here. */
       return -ENODEV;
}

Para instalar este modulo (una vez modificado) debes ejecutar:

make -C /lib/modules/2.6.22-14-generic/build  M=`pwd` modules

Sino hay errores, con esto debería ser todo lo que debes instalar. En mi caso, ahora ya no tengo que arrancar windows para mantener con carga mi iPod Touch.

Etiquetas: , , , , ,

Driver ATi 8.42 con soporte AIGLX

Después de tanto tiempo AMD y ATI estan dando buenas señales para los usuarios de GNU/Linux. ATI ha liberado la versión 8.42.3 de su driver fglrx que entre otros parches y correcciones, incluye el soporte para AIGLX. Está es un buena noticia, ya que como sabrán para Usar adecuadamente el driver ATi con Beryl o CompizFusión se debía instalar el servidor XGL, que no era precisamente lo más estable.

Bien por ATi, ahora solo nos queda prender una vela y esperar que el driver sea más estable ahora que usará AIGLX.

Descargar » Driver ATi 8.42.3.

Etiquetas: ati, amd, aiglx, drivers, hardware, gnu/linux, fglrx