WordPress 2.3.2

Parece que el Equipo de WordPress no quiso cerrar el año sin antes dejarnos un regalo, la versión 2.3.2 de WordPress. En esta versión se corrigen estos problemas:

  • Un problema de seguridad que puede exponer los borradores
  • Ya no se muestran errores que se produzcan al ejecutar consultas, asumiendo que es un ambiente de producción y no uno de desarrollo. Para activar esta característica se debe definir:
    defined('WP_DEBUG', true)
  • Otros problemas de seguridad con la API via XMLRPC

Como agregado, ahora se pueden personalizar la página de error al conectarse a la base de datos, sin tener que modificar el código de WordPress. Basta con crear el archivo wp-content/db-error.php para que funcione.

Ha actualizarse entonces…

Etiquetas: wordpress, wordpress 2.3

2 thoughts on “WordPress 2.3.2

  1. Listo mixto… ambos sitios LAGDP y Crónicas efímeras corren sobre WP 2.3.2 con las últimas actualizaciones de todos los plugins. 😉

    No hay nada como un este comando para actualizar WP:

    svn sw http://svn.automattic.com/wordpress/tags/2.3.2/

    No más aseguraté de no borrar la plantilla CLASSIC de la carpeta de THEMES porque si no toda la automatización del comando SVN se va al carajo y te responde con “Directory ‘wp-content/themes/classic’ is missing” y ya no funciona más.

    ¿Quién iba a suponer que el theme CLASSIC es parte integral de WordPress ahora y que no debe borrarse bajo ninguna circunstancia?

  2. Dichoso, pero cuando tienes un WordPress personalizado no queda de otra más que seguir siendo varoncito y hacer las actualizaciones con diff‘s y cp‘s.

    En realidad el tema clásico no es parte integral de WP pero si es necesario que esté a la hora de actualizar las archivos con Subversion. Es como funciona SVN, no WP. Creo que con svn ignore se puede solucionar, pero no recuerdo muy bien como era la cosa …

Comments are closed.