GoPHP5.org, quitando el soporte a PHP4

GoPHP5PHP4 ya tiene siete años de haber se liberado, y PHP5 ya casi llega a los 3 años de estar en el aire; pero a pesar de ello muchos hostings aun no han agregado soporte para php5 por temor a que las aplicaciones de sus clientes no funcionen, o al menos no lo activan por defecto. De acuerdo con Nexen.net el 80% de los hostings aún continuan usando php4 en sus servidores.

Es por ello que nace GoPHP5.org, como una iniciativa para que los proyectos basados en php abandonen el soporte a PHP4 y se pasen a PHP5, aprovechando sus ventajas; así como comprometer a los hostings para que ellos también eliminen php4 de sus servidores.

La meta es llegar 5 de Febrero de 2008 con el mínimo soporte para php4. Proyectos como Drupal 7 y phpMyAdmin ya se han comprometido a esta iniciativa, y otros como MediaWiki desde ya solo corren en php5. En la lista de correo wp-hackers ya han discutido el cambio hacia php5 varias veces ya. La respuesta siempre ha sido: cuando exista mayor soporte de php5. Haber que pasa esta vez 😉

Etiquetas de búsqueda: , , , , ,

10 thoughts on “GoPHP5.org, quitando el soporte a PHP4

  1. Es interesante iniciativa y ojalá tenga éxito. Pero haciendo una analogía, a pesar que Microsoft ha metido soporte y todo su poder por impulsar su asp.net, conozco muchos sitios, hosting, empresas y personas que no se despegan del asp anterior.

    lógico, la filosofía de la gente que estamos con opciones libres es distinta, no tenemos al cambio ni esperamos que nos lleven de la manita y estoy seguro que la iniciativa obligará a los hostings a modernizarse. En dreamhost por ejemplo ya todos mis sitios están con php5.

  2. Yo también he escuchado a personas decir que php4 es más rápido que php5 y que da menos problemas al actualizar de versión (y tiene razón porque es cierto jejeje). Pero como mencionaban en WP-Hackers, la gente no se cambiará a php5 hasta que no se vean obligados a hacerlo. Me recorde del dicho: “si algo funciona no lo repares” 😉

  3. De hecho como te comentaba, Debian va a quitar el php4 de sus repositorios, porl o que todos los paquetes que dependían de php4, los tienen que migrar a php5 para que no tengan bugs.

    Asi que tendremos unas de las mayores migraciones jamás vistas.

    Saludos!!!

  4. Pingback: SigT

  5. Pingback: Fin del ciclo de vida para PHP4 « Javier Aroche

  6. Pingback: Fin del ciclo de vida para PHP4

  7. Pingback: PHP5, ¿un problema para los CMS? CMSTECNO

  8. Pingback: PHP4 ha muerto, larga vida a PHP5

  9. Pingback: Llegó la hora de cambiarse a PHP5 | LinkAlicante

Comments are closed.